偵測涵蓋率

實測數據,不是空口宣稱。

使用樣本檔案進行的歷史測量。請查看各列日期;這些結果不能證明目前版本的能力。n/a 表示未測量。

RAW、PDF、H.264/H.265、MP3/M4A 和 DICOM 尚無已獲認可的目前整檔偵測率。歷史樣本、結構檢查及特定變體的結果不能證明對整個格式的完整涵蓋。

影像與相片

格式SniperBolterNuke (legacy shotgun)實測樣本
PNG 影像PNG100%100%100%336 KB
JPEG XL 影像JXL87%97%100%344 KB
WebP 影像WebP83%82%84%198 KB
macOS 圖示ICNS97%97%100%234 KB
Flash SWFSWF100%100%100%23 KB
SVG 向量圖形SVG45%98%99%29 KB
Windows 圖示ICO63%54%70%226 KB
QOI 影像QOI0%0%0%22 KB
JPEG2000 影像JPEG2K6%5%97%1.8 MB
GIF 影像GIF9%35%100%400 KB
JPEG 影像JPEG4%8%100%750 KB
OpenEXR HDR 影像EXR1%0%100%388 KB
Adobe PhotoshopPSD2%2%50%1.8 MB
HEIC/HEIF 影像HEIC0%0%4%2.9 MB
AVIF 影像AVIF0%0%1%85 KB
BMP 影像BMP0%0%0%900 KB
DPX 影像DPX0%0%0%1.8 MB
Portable Anymap 影像PAM/PPM0%0%0%1.8 MB
TGA 影像TGA25%27%100%11 KB
TIFF 影像TIFF63%93%100%175 KB
JBIG2 雙階影像JBIG20%n/an/a860 B

相機 RAW

格式SniperBolterNuke (legacy shotgun)實測樣本
Adobe DNG RAWDNG3%3%3%75.2 MB
Canon CR2 RAWCR22%1%6%5.5 MB
Nikon RAWNEF0%0%0%2.1 MB
Sony RAWARW0%4%15%5.9 MB
Fuji RAWRAF0%0%2%198.4 MB
NRW0%1%0%15.7 MB
Olympus RAWORF0%0%0%13.3 MB
Pentax RAWPEF0%0%0%10.6 MB
Panasonic RAWRW20%0%0%10.4 MB
Canon CR3 RAWCR3 (Canon)0%0%0%15.0 MB

影片

格式SniperBolterNuke (legacy shotgun)實測樣本
Matroska 視訊MKV100%100%100%456 KB
AV1 視訊AV15%6%100%7 KB
MPEG 傳輸串流MPEG-TS4%5%100%141 KB
標準 MIDI 檔MIDI15%94%100%20 KB
Apple ProRes 視訊ProRes/MOV5%7%78%6.3 MB
MP4 視訊MP40%0%66%1022 KB
QuickTime 視訊MOV1%1%75%1022 KB
WebM 視訊WebM (VP9+Opus)86%69%78%1.7 MB
WebM 視訊WebM (VP8)88%n/a90%1.0 MB
AVI 視訊AVI0%20%93%8.1 MB
DV 視訊DV0%3%0%351 KB
MPEG 基本串流MPEG-ES0%0%0%30 KB
MPEG 節目串流MPEG-1/20%0%0%16 KB
MPEG-4 Part 20%0%0%1.2 MB
RealMediaRM0%1%2%13 KB
Flash 視訊FLV40%n/an/a33 B
MPEG 節目串流MPEG-PS0%n/an/a2 KB
Ogg 視訊 (Theora)Theora (.ogv)100%n/a100%50 KB
IVF 視訊容器VP8 (raw IVF)0%0%0%9 KB

音訊

格式SniperBolterNuke (legacy shotgun)實測樣本
Dolby Digital AC-3 音訊AC3100%100%100%2.0 MB
Ogg 音訊OGG100%100%100%102 KB
Dolby Digital Plus 音訊E-AC3 (large)100%n/a100%4.0 MB
Dolby Digital Plus 音訊E-AC3 (small)81%100%85%1.2 MB
FLAC 音訊FLAC80%96%88%43 KB
Apple Lossless 音訊ALAC1%0%100%17 KB
Opus1%62%35%54 KB
M4A 音訊AAC (M4A)4%3%31%15 KB
AAC-LC 音訊 (ADTS)AAC (ADTS)6%10%20%9 KB
MP3 音訊MP31%0%1%48 KB
WAV 音訊WAV0%0%2%8 KB
AIFF 音訊AIFF0%0%1%7 KB
CAF 音訊CAF0%0%1%8 KB
AU/SND 音訊AU0%0%0%8 KB
ProTracker 模組Tracker (MOD)0%0%0%301 KB
AMR 音訊AMR14%n/an/a38 B
Monkey's AudioAPE (Monkey's Audio)99%100%100%15 KB
CD+Graphics 卡拉OKCD+G (Karaoke)0%0%2%14 KB
DSDIFF 音訊DFF (DSDIFF)52%n/an/a32 B
DSD 串流檔DSF (DSD)60%n/an/a88 B
DTS Digital Surround 音訊DTS (Digital Surround)0%0%51%369 KB
True Audio (TTA)TTA (True Audio)97%n/an/a3 KB
WavPack 音訊WavPack100%100%100%117 KB

文件與辦公

格式SniperBolterNuke (legacy shotgun)實測樣本
Excel 試算表 (97-2003)XLS22%24%96%174 KB
Word 文件 (97-2003)DOC (large)2%2%2%589 KB
Word 文件 (97-2003)DOC (small)n/an/a52%19 KB
PDF 文件PDFn/an/an/an/a
PowerPoint (97-2003)OLE2 (PPT)0%0%0%891 KB
Adobe InDesign 文件InDesign1%0%73%4 KB
Word 文件 (OOXML)DOCX87%82%100%13 KB
Excel 試算表 (OOXML)XLSX82%83%100%10 KB
PowerPoint (OOXML)PPTX93%97%100%35 KB
OpenDocument 文字ODT96%98%100%23 KB
OpenDocument 試算表ODS88%88%100%8 KB
OpenDocument 簡報ODP97%98%100%23 KB
RTF 格式文字RTF0%0%92%1.2 MB
EML 電子郵件訊息EML12%97%84%6 KB
MBOX 郵件封存檔MBOX13%100%100%16 KB
Apple PagesPages100%99%100%56 KB
Apple KeynoteKeynote99%100%100%64 KB
Apple NumbersNumbers100%99%100%64 KB
Adobe IllustratorAI (Adobe Illustrator)6%n/an/a372 B
BAI2 餘額報告BAI2 (Bank Admin Inst.)20%n/an/a362 B
CSV 資料CSV26%100%100%23 KB
ClarisWorks/AppleWorksClarisWorks6%n/an/a64 B
UN/EDIFACTEDIFACT37%n/an/a152 B
Encapsulated PostScriptEPS4%n/an/a430 B
EPUB 電子書EPUB69%n/an/a1 KB
HTML 文件HTML22%100%100%34 KB
iCalendariCalendar (RFC 5545)21%n/an/a650 B
Adobe InDesign 標記語言IDML (InDesign)55%n/an/a884 B
INI 設定檔INI17%n/an/a60 B
JSON 資料JSON43%100%100%33 KB
JSON530%n/an/a329 B
SWIFT MT940 銀行對帳單MT940 (SWIFT)11%n/an/a347 B
MacWrite 文件MacWrite Document0%n/an/a64 B
NACHA/ACH 電子支付NACHA (ACH)15%n/an/a950 B
Open Financial ExchangeOFX (Open Financial)2%n/an/a850 B
純文字 (UTF-8)Plain Text0%0%95%17 KB
Pro Tools 工作階段PTX (Pro Tools)0%0%0%39 KB
Quicken Interchange FormatQIF (Quicken Interchange)3%n/an/a218 B
TOML 設定檔TOML42%100%100%33 KB
Tax Exchange FormatTXF (Tax Exchange)3%n/an/a140 B
vCardvCard (RFC 6350)32%n/an/a198 B
WordPerfect 文件WordPerfect2%n/an/a512 B
X12 EDI21%n/an/a262 B
XML 文件XML52%100%100%40 KB
YAML 資料YAML0%n/an/a68 B
Markdown 文字Markdown0%n/an/a525 B

字型

格式SniperBolterNuke (legacy shotgun)實測樣本
TrueType 字型TTF100%100%100%607 KB
OpenType 字型OTF100%100%100%327 KB
WOFF 字型WOFF100%100%100%254 KB
WOFF2 字型WOFF249%63%100%172 KB

科學

格式SniperBolterNuke (legacy shotgun)實測樣本
FITS 天文資料FITS (with CHECKSUM)100%n/a100%5 KB
FITS 天文資料FITS (no CHECKSUM)0%0%2%683 KB
DICOM 醫學影像DICOM7%9%20%38 KB
HDF5 科學資料HDF54%72%13%6 KB
PDB 蛋白質結構PDB (Protein)16%19%39%48 KB
CIF 晶體學資料CIF (Crystallographic Info)0%n/an/a145 B
FASTA 序列FASTA22%n/an/a479 B
FASTQ 定序讀數FASTQ28%n/an/a447 B
MATLAB 資料MAT-File94%n/an/a1 KB
NetCDF 科學資料NetCDF39%n/an/a84 B
NIfTI 神經影像NIfTI-11%n/an/a416 B
Apache Parquet 資料Parquet2%n/an/a484 B
ESRI ShapefileShapefile89%n/an/a128 B

資料庫

格式SniperBolterNuke (legacy shotgun)實測樣本
QuickBooks 公司檔QBW100%100%100%14.4 MB
SQLite 資料庫SQLite54%52%100%984 KB
Microsoft Access 資料庫ACCDB1%0%73%4 KB
Microsoft Access 資料庫 (97-2003)MDB1%0%73%4 KB
QuickBooks 備份QuickBooks Backup (.qbb)8%7%24%19 KB
dBASE 資料庫dBASE (.dbf)0%0%100%20 KB

壓縮檔

格式SniperBolterNuke (legacy shotgun)實測樣本
Compact Pro 封存檔CPT100%100%100%19 KB
Tar 封存檔TAR15%78%73%4 KB
7-Zip 封存檔7z99%n/a100%16 KB
Unix ar 封存檔AR (Unix archive)38%n/an/a88 B
Brotli 壓縮檔Brotli47%72%100%26 KB
Bzip2 壓縮檔Bzip2100%100%100%16 KB
Microsoft Cabinet 封存檔CAB (Microsoft)100%100%100%26 KB
Gzip 壓縮檔Gzip100%100%100%16 KB
BinHex 4.0 封存檔BinHex (.hqx)100%100%100%13 KB
PAR2 同位校驗封存檔PAR2100%100%100%33 KB
RAR 封存檔RAR100%100%100%16 KB
StuffIt 封存檔StuffIt94%n/an/a140 B
XZ 壓縮檔XZ100%100%100%16 KB
ZIP 封存檔ZIP100%100%100%16 KB
Zstandard 壓縮檔Zstd100%100%100%16 KB
Studio One 專案Studio One Project (.song)100%99%100%41 KB
StuffIt X 封存檔StuffIt X (.sitx)0%0%0%16 KB

遊戲 ROM

格式SniperBolterNuke (legacy shotgun)實測樣本
SNES ROMSNES100%100%99%512 KB
Game Boy ROMGB0%100%1%128 KB
Game Boy Advance ROMGBA0%0%0%8.0 MB
Sega Genesis ROMGenesis0%100%1%512 KB
NES ROMNES0%0%0%128 KB
Nintendo 64 ROMN640%10%0%8.0 MB
MAME CHD 映像CHD (MAME)10%n/an/a124 B
Nintendo DS ROMNDS (Nintendo DS)41%n/an/a1 KB
DOOM WAD 封存檔WAD (Doom/Wii)100%n/an/a12 B

磁碟映像 / 檔案系統 / 執行檔 / 其他

格式SniperBolterNuke (legacy shotgun)實測樣本
Apple 磁碟映像DMG0%0%10%16 KB
ISO 9660 磁碟映像ISO0%0%0%350 KB
COFF 目的檔COFF0%0%1%10 KB
Mach-O 通用二進位檔Mach-O Fat0%0%0%32 KB
Blorb 互動式小說Blorb0%0%0%3.0 MB
macOS DS_StoreDS_Store0%0%25%10 KB
ASF 媒體ASF1%4%0%6 KB
Quicken 資料檔QDF1%1%0%4.9 MB
3MF 3D 製造3MF (3D Manufacturing)75%n/an/a1 KB
Adobe After Effects 專案AEP (After Effects Project)27%n/an/a44 B
Ableton Live SetALS (Ableton Live Set)90%n/an/a82 B
Apple 媒體櫃資料庫Apple Media DB46%n/an/a253 B
GarageBand 專案GarageBand (.band)0%n/an/a512 B
Erlang/Elixir BEAM 位元組碼BEAM (Erlang)36%n/an/a736 B
Blender 3D 專案Blender (.blend)47%n/an/a104 B
BSP 地圖檔BSP (Quake)39%n/an/a1 KB
Bitwig Studio 專案Bitwig Project0%n/an/a128 B
Chromium 資源 PAKChromium PAK0%n/an/a30 B
Cubase 專案Cubase Project49%n/an/a76 B
DER 憑證/金鑰DER (ASN.1)7%n/an/a688 B
DaVinci Resolve 專案DRP (DR Painter)60%n/an/a263 B
AutoCAD 圖檔DWG (AutoCAD)1%n/an/a1 KB
AutoCAD DXFDXF (AutoCAD)5%n/an/a388 B
EEx/ERB 範本Erlang Mix .eex0%n/an/a378 B
ELF 執行檔ELF20%n/an/a64 B
Erlang TermErlang BERT0%n/an/a281 B
Final Cut Pro XMLFCPXML (Final Cut)58%n/an/a134 B
FL Studio 專案FL Studio6%n/an/a122 B
GLB 二進位 glTFGLB (glTF binary)32%n/an/a1 KB
glTF 3D 場景glTF (JSON)20%n/an/a2 KB
IFF 容器IFF (EA)46%n/an/a232 B
Java Class 檔Java .class21%n/an/a397 B
KML 地理資料KML58%n/an/a1 KB
KMZ 壓縮 KMLKMZ95%n/an/a538 B
Logic Pro X 專案Logic Pro X71%n/an/a249 B
Larian Studios PAKLSPK (Larian Studios)3%n/an/a256 B
Mach-O 二進位檔Mach-O0%n/an/a536 B
Wavefront OBJ 3D 模型OBJ (Wavefront)44%n/an/a652 B
Quake PAK 封存檔PAK (Quake)60%n/an/a12 B
Windows PE 執行檔PE (Windows)3%n/an/a1 KB
PEM 憑證/金鑰PEM (RFC 7468)51%n/an/a989 B
PGP 簽署訊息PGP Signed Message81%n/an/a370 B
Apple Property ListPlist52%n/an/a830 B
PLY 多邊形檔PLY (3D)51%n/an/a447 B
Adobe Premiere Pro 專案Premiere Project55%n/an/a112 B
Reason 專案Reason (Propellerhead)33%n/an/a96 B
Reaper 專案RPP (Reaper)50%n/an/a44 B
Sketch 設計檔Sketch (.sketch)56%n/an/a631 B
SSH 簽章SSH Signature64%n/an/a294 B
STEP CAD 模型STEP (.step)23%n/an/a711 B
STL 3D 模型STL (3D)73%n/an/a518 B
Roxio Toast 光碟映像Toast (Roxio)0%0%10%36 KB
Type 1 字型Type 1 Font0%n/an/a174 B
VMware 虛擬磁碟VMDK0%0%0%64 KB
Valve PAK 封存檔VPK (Valve Pak)100%n/an/a28 B
WARC 網頁封存檔WARC (Web Archive)48%n/an/a1 KB
WebAssembly 模組WebAssembly35%n/an/a24 B
Windows Imaging FormatWIM (Windows Imaging)8%n/an/a1 KB
Microsoft 安裝程式Microsoft Installer (.msi)0%0%43%9 KB
Windows ESD 映像Windows ESD (.esd)1%0%0%16 KB
LLVM 預先編譯標頭檔LLVM Precompiled Header (.pch)0%0%0%16 KB
LLVM 序列化診斷LLVM Serialized Diagnostics (.dia)0%0%0%16 KB
PCAP 網路擷取PCAP4%3%100%13 KB
PCAPNG 網路擷取PCAPNG10%8%100%9 KB
G-code (3D 印表機/CNC)G-code27%99%98%20 KB
MessagePack 資料MessagePack (.msgpack)0%0%0%19 KB
RPM 軟體套件RPM Package (.rpm)3%7%30%22 KB